Browse Source

Attempt to fix Java 8 compatibility

mistress
Agatha 4 months ago
parent
commit
c47a724871
Signed by: sorceress <agatharose@wantscuddl.es> GPG Key ID: 2DB18BA2E0A80BC3
2 changed files with 4 additions and 3 deletions
  1. +1
    -1
      gradle.properties
  2. +3
    -2
      src/main/java/dev/agatharose/asbestos/item/ScraperItem.java

+ 1
- 1
gradle.properties View File

@@ -8,7 +8,7 @@ org.gradle.jvmargs=-Xmx1G
loader_version=0.10.7

# Mod Properties
mod_version = 1.0
mod_version = 1.0.1
maven_group = dev.agatharose
archives_base_name = asbestos



+ 3
- 2
src/main/java/dev/agatharose/asbestos/item/ScraperItem.java View File

@@ -1,6 +1,7 @@
package dev.agatharose.asbestos.item;

import java.util.Set;
import java.util.Arrays;
import java.util.HashSet;

import dev.agatharose.asbestos.Asbestos;
import net.minecraft.item.MiningToolItem;
@@ -9,6 +10,6 @@ import net.minecraft.item.ToolMaterial;
public class ScraperItem extends MiningToolItem {

public ScraperItem(ToolMaterial material, float attackDamage, float attackSpeed, Settings settings) {
super(attackDamage, attackSpeed, material, Set.of(Asbestos.ASBESTOS_BLOCK), settings);
super(attackDamage, attackSpeed, material, new HashSet<>(Arrays.asList(Asbestos.ASBESTOS_BLOCK)), settings);
}
}

Loading…
Cancel
Save