40 lines
754 B
Nix
40 lines
754 B
Nix
{ pkgs, lib, ... }:
|
|
{
|
|
boot = {
|
|
initrd.kernelModules = [
|
|
"vfio_pci"
|
|
"vfio"
|
|
"vfio_iommu_type1"
|
|
|
|
"amdgpu"
|
|
];
|
|
|
|
kernelParams =
|
|
let
|
|
gpuIDs = [
|
|
"1002:67df" # Graphics
|
|
"1002:aaf0" # Audio
|
|
];
|
|
in
|
|
[
|
|
# enable IOMMU
|
|
"amd_iommu=on"
|
|
("vfio-pci.ids=" + lib.concatStringsSep "," gpuIDs)
|
|
];
|
|
};
|
|
|
|
hardware.opengl.enable = true;
|
|
virtualisation.spiceUSBRedirection.enable = true;
|
|
services.openssh.settings.X11Forwarding = true;
|
|
|
|
# Virtualization
|
|
virtualisation.libvirtd = {
|
|
enable = true;
|
|
onBoot = "start";
|
|
onShutdown = "shutdown";
|
|
};
|
|
|
|
programs.virt-manager.enable = true;
|
|
users.users.agatha.extraGroups = [ "libvirtd" ];
|
|
}
|