nix-infra/common/fragments/yubikey.nix

13 lines
286 B
Nix

{ pkgs, ... }: {
services.udev.packages = with pkgs; [ libu2f-host yubikey-personalization ];
programs.gnupg.agent = {
enable = true;
enableSSHSupport = true;
pinentryPackage = pkgs.pinentry-gnome3;
enableExtraSocket = true;
};
services.pcscd.enable = true;
}