typst-env/flake.nix

14 lines
339 B
Nix

{
description = "Typst dev environment";
inputs = { nixpkgs.url = "nixpkgs/nixos-unstable"; };
outputs = { self, nixpkgs }: {
devShells."x86_64-linux".default =
let pkgs = import nixpkgs { system = "x86_64-linux"; };
in pkgs.mkShell {
buildInputs = with pkgs; [ typst typst-lsp typst-fmt ];
};
};
}