oops 42069

This commit is contained in:
xenia 2024-12-21 16:12:25 -05:00
parent bd3d9212a4
commit 0e8de3ebd5
1 changed files with 11 additions and 7 deletions

View File

@ -1,14 +1,14 @@
From 72257e171df999f878a250495a77247a9c5da68b Mon Sep 17 00:00:00 2001
From d184f40d429826daa95bd0065667d03f7cb02436 Mon Sep 17 00:00:00 2001
From: xenia <xenia@awoo.systems>
Date: Sat, 21 Dec 2024 15:33:10 -0500
Subject: [PATCH] implement lix support
---
CMakeLists.txt | 27 ---------------------------
extra-builtins.cc | 27 +++------------------------
extra-builtins.cc | 28 ++++------------------------
meson.build | 18 ++++++++++++++++++
nix-plugins-config.h.in | 3 ---
4 files changed, 21 insertions(+), 54 deletions(-)
4 files changed, 22 insertions(+), 54 deletions(-)
delete mode 100644 CMakeLists.txt
create mode 100644 meson.build
delete mode 100644 nix-plugins-config.h.in
@ -47,7 +47,7 @@ index 9674fe8..0000000
-
-install(TARGETS nix-extra-builtins DESTINATION lib/nix/plugins)
diff --git a/extra-builtins.cc b/extra-builtins.cc
index 3a0f90e..a96e7c7 100644
index 3a0f90e..74f7209 100644
--- a/extra-builtins.cc
+++ b/extra-builtins.cc
@@ -1,12 +1,8 @@
@ -63,7 +63,7 @@ index 3a0f90e..a96e7c7 100644
using namespace nix;
@@ -24,9 +20,8 @@ static GlobalConfig::Register rp(&extraBuiltinsSettings);
@@ -24,12 +20,12 @@ static GlobalConfig::Register rp(&extraBuiltinsSettings);
static void extraBuiltins(EvalState & state, const PosIdx pos,
Value ** _args, Value & v)
{
@ -75,7 +75,11 @@ index 3a0f90e..a96e7c7 100644
try {
auto fun = state.allocValue();
@@ -56,7 +51,7 @@ static void extraBuiltins(EvalState & state, const PosIdx pos,
+ state.allowPath(extraBuiltinsFile.path.abs());
state.evalFile(extraBuiltinsFile, *fun);
Value * arg;
if (evalSettings.enableNativeCode) {
@@ -56,7 +52,7 @@ static void extraBuiltins(EvalState & state, const PosIdx pos,
}
v.mkApp(fun, arg);
state.forceValue(v, pos);
@ -84,7 +88,7 @@ index 3a0f90e..a96e7c7 100644
v.mkNull();
}
}
@@ -66,19 +61,3 @@ static RegisterPrimOp rp1({
@@ -66,19 +62,3 @@ static RegisterPrimOp rp1({
.arity = 0,
.fun = extraBuiltins,
});