oops 42070
This commit is contained in:
parent
0e8de3ebd5
commit
5e2bfd4065
|
@ -1,14 +1,14 @@
|
|||
From d184f40d429826daa95bd0065667d03f7cb02436 Mon Sep 17 00:00:00 2001
|
||||
From db0c0622ec4bfdc18e1ff53f47f0b922dacb111f Mon Sep 17 00:00:00 2001
|
||||
From: xenia <xenia@awoo.systems>
|
||||
Date: Sat, 21 Dec 2024 15:33:10 -0500
|
||||
Subject: [PATCH] implement lix support
|
||||
|
||||
---
|
||||
CMakeLists.txt | 27 ---------------------------
|
||||
extra-builtins.cc | 28 ++++------------------------
|
||||
extra-builtins.cc | 29 +++++------------------------
|
||||
meson.build | 18 ++++++++++++++++++
|
||||
nix-plugins-config.h.in | 3 ---
|
||||
4 files changed, 22 insertions(+), 54 deletions(-)
|
||||
4 files changed, 23 insertions(+), 54 deletions(-)
|
||||
delete mode 100644 CMakeLists.txt
|
||||
create mode 100644 meson.build
|
||||
delete mode 100644 nix-plugins-config.h.in
|
||||
|
@ -47,7 +47,7 @@ index 9674fe8..0000000
|
|||
-
|
||||
-install(TARGETS nix-extra-builtins DESTINATION lib/nix/plugins)
|
||||
diff --git a/extra-builtins.cc b/extra-builtins.cc
|
||||
index 3a0f90e..74f7209 100644
|
||||
index 3a0f90e..7262d2f 100644
|
||||
--- a/extra-builtins.cc
|
||||
+++ b/extra-builtins.cc
|
||||
@@ -1,12 +1,8 @@
|
||||
|
@ -63,7 +63,7 @@ index 3a0f90e..74f7209 100644
|
|||
|
||||
using namespace nix;
|
||||
|
||||
@@ -24,12 +20,12 @@ static GlobalConfig::Register rp(&extraBuiltinsSettings);
|
||||
@@ -24,12 +20,13 @@ static GlobalConfig::Register rp(&extraBuiltinsSettings);
|
||||
static void extraBuiltins(EvalState & state, const PosIdx pos,
|
||||
Value ** _args, Value & v)
|
||||
{
|
||||
|
@ -76,10 +76,11 @@ index 3a0f90e..74f7209 100644
|
|||
try {
|
||||
auto fun = state.allocValue();
|
||||
+ state.allowPath(extraBuiltinsFile.path.abs());
|
||||
+ state.allowPath(state.checkSourcePath(extraBuiltinsFile).path.abs());
|
||||
state.evalFile(extraBuiltinsFile, *fun);
|
||||
Value * arg;
|
||||
if (evalSettings.enableNativeCode) {
|
||||
@@ -56,7 +52,7 @@ static void extraBuiltins(EvalState & state, const PosIdx pos,
|
||||
@@ -56,7 +53,7 @@ static void extraBuiltins(EvalState & state, const PosIdx pos,
|
||||
}
|
||||
v.mkApp(fun, arg);
|
||||
state.forceValue(v, pos);
|
||||
|
@ -88,7 +89,7 @@ index 3a0f90e..74f7209 100644
|
|||
v.mkNull();
|
||||
}
|
||||
}
|
||||
@@ -66,19 +62,3 @@ static RegisterPrimOp rp1({
|
||||
@@ -66,19 +63,3 @@ static RegisterPrimOp rp1({
|
||||
.arity = 0,
|
||||
.fun = extraBuiltins,
|
||||
});
|
||||
|
|
Loading…
Reference in New Issue