39 lines
930 B
Nix
39 lines
930 B
Nix
{
|
|
lib,
|
|
fetchgit,
|
|
buildDunePackage,
|
|
|
|
cstruct,
|
|
dune-configurator,
|
|
eio,
|
|
eio_linux,
|
|
eio_main,
|
|
ppx_unicode,
|
|
ptime,
|
|
xlog,
|
|
}:
|
|
buildDunePackage rec {
|
|
pname = "systemd-ml";
|
|
version = "0.1.0";
|
|
|
|
src = fetchgit {
|
|
url = "https://git.lain.faith/haskal/systemd-ml.git";
|
|
rev = version;
|
|
hash = "sha256-IkWBObwQJF5wum46OsLTH1wmPqWnF5/UuTnBFbs/o/0=";
|
|
};
|
|
|
|
minimalOcamlVersion = "5.1";
|
|
dontStrip = true;
|
|
|
|
nativeBuildInputs = [ dune-configurator ppx_unicode ];
|
|
propagatedBuildInputs = [ cstruct dune-configurator eio eio_linux eio_main ppx_unicode ptime xlog ];
|
|
|
|
meta = {
|
|
description = "systemd-ml provides libsystemd-like functionality for interacting with the systemd service manager, in self-contained ocaml code (with a bit of C).";
|
|
homepage = "https://git.lain.faith/haskal/systemd-ml";
|
|
license = lib.licenses.fyptl;
|
|
maintainers = [];
|
|
platforms = lib.platforms.linux;
|
|
};
|
|
}
|