ppx_unicode/package.nix

32 lines
434 B
Nix

{
lib,
mkShell,
gitSource,
buildDunePackage,
ppxlib,
uunf,
ocaml,
dune_3,
odoc,
utop,
enableShell ? false
}:
buildDunePackage rec {
pname = "ppx_unicode";
version = "0.1.0";
src = gitSource { root = ./.; };
minimalOCamlVersion = "5.1";
dontStrip = true;
propagatedBuildInputs = [ ppxlib uunf ];
nativeBuildInputs = [ ppxlib ] ++ lib.optionals enableShell [
ocaml dune_3 odoc utop
];
}